Publicado en Español

Samsung I5700 Galaxy Spica Android 2.2 con ubuntu

Tengo un Samsung I5700 que conseguí al pasar a Yoigo, después de esperar varios meses a que se actualizase. Parece ser que Samsung no va a actualizar a Android 2.2 próximamente. Mi único problema es la batería, con que me lance a la aventura de actualizar bajo ubuntu.

Conseguir Root

Para hacerlo se necesita la aplicación «Odin Multiple downloader» creada por Samsung y que solo esta disponible con windows. Pero hay una solución y es utilizar virtualbox, una vez dentro de la maquina virtual

Ahora necesitamos que el telefono admita el kernel. Necesitamos que  el teléfono se ponga en modo descarga.

  • Desconecta el USB del equipo
  • Apágalo y  pulsa «Bajar Volumen + Apagado + Boton Camara»
  • Aparece un icono en el teléfono que dice downloading
  • Conecta el USB al equipo
  • En la maquina virtual se reconoce un modem
  • Ejecuta Odin y espera a que se reconozca un puerto COM
  • Selecciona el fichero spica_j3.ops (se descargo con odin)
  • Selecciona en el boton PDA seleciona el fichero del kernel descomprimido

Ahora debes esperar 5 minutos a que el proceso se complete. Ya tienes root en el dispositivo!

Segunda parte

Ahora debes reemplaza la versión 2.1 por la 2.2, para ello:

  • Descarga CM-6.1.1-Spica-XXXX_update.zip (Busca CyanogenMod-6.1.1-Spica en
    Forum: 2.2 (Froyo) Development/Releases)
  • Apágalo y  pulsa «Bajar Volumen + Contestar +  Apagado»
  • CM Recovery: Mounts and Storage > mount USB storage
  • Copia CM-6.1.1-Spica-XXXX_update.zip al raiz del dispositivo usb
  • CM Recovery:  Install zip from sdcard > choose zip from sdcard
  • CM Recovery: Wipe > wipe cache & data/cache
  • Reboot

Referencias:

Samsung I5700 Galaxy Spica Android 2.1 Flashing Guide | All About Web & Mobile Application Development.

http://myandroidphones.blogspot.com/2010/05/samsung-i5700-galaxy-spica-android-21.html

Publicado en Español

Instalar software DNIe en ubuntu 10.04

Debido a que www.dnielectronico.es ha publicado una version especifica del software para usar el DNI Electronico. Estas son las instrucciones basicas de como instalarlo en Ubuntu 10.04 «Lucid Lynx»

1) Instala el demonio

sudo aptitude install pcscd

2) Instala el paquete especifido  (y dependencias)

Ubuntu_Lucid_Linx_32bits

3) Registra Modulo DNIE PKCS#11

Aplicaciones > Oficina > Registra Modulo DNIE PKCS#11

Decirme si os funciona